Welcome, Guest. Please login or register.
October 18, 2019, 01:59:05 PM


Author Topic: Lack of menu options - specially firmware  (Read 6579 times)

Offline Jacky T

  • New Member
  • *
  • Posts: 2
Lack of menu options - specially firmware
« on: April 22, 2014, 12:56:37 AM »
Hey all,

Done a bitta hunting around (yes in manual too) but cant seem to find anything except one obscure vid that represents what I see on my 550d rebel T2i menu screen.

Trying to currently update my firmware but there seems to be menu options missing when compared to the other menu screens that others seem to have.

Specifically there is no third 'yellow spanner' option that allows the firmware to be viewed and updated - do i have to format my card before these options show up? Or is my camera an earlier model that has a dif way to update firmware from the prevailing norm I see.

attached a pic pf menu screen (sorry re quality, couldnt seem to find my 550d to take it ;) )

Offline Craig

  • Sr. Contributor
  • *
  • Posts: 581
Re: Lack of menu options - specially firmware
« Reply #1 on: April 22, 2014, 06:04:26 AM »
Put your camera in AV, TV, or M mode and try again.
6D, T2i, Canon 600EX, 430EXII, and some other stuff my wife doesn't know about.

Offline AndyCivil

  • Moderator
  • *
  • Posts: 2412
Re: Lack of menu options - specially firmware
« Reply #2 on: April 22, 2014, 06:06:06 AM »
You need your dial in "P" mode or higher for the other options to appear.

This habit of hiding the more obscure options is something I find frustrating about Canon. It must be nearly a decade ago now that I bought my Canon SD600 and one of the features I liked was its long shutter speed. I was at Niagara falls, and put the camera on a flat surface to take a long exposure of the lights at night - the longest shutter I could get was about 1/8 sec! Apparently this crap was because I was in Auto... when I switched to "P" mode, I got the long shutter speed. D'oh!
« Last Edit: April 22, 2014, 06:09:53 AM by AndyCivil »

Offline Jacky T

  • New Member
  • *
  • Posts: 2
Re: Lack of menu options - specially firmware
« Reply #3 on: April 25, 2014, 01:14:54 AM »
Thankyou both very much!